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Technical Article   Error:  Unable to start ArcSDE, Please check for zombie processes

Article ID: 36864
Software:  ArcSDE 9.0, 9.1, 9.2, 9.3, 9.3.1
Platforms:  Solaris 9, 10

Error Message

When starting the ArcSDE service on a Solaris 9 or Solaris 10 machine, the following error message is returned: "Unable to start ArcSDE, Please check for zombie processes".

Cause

This error can have multiple causes.

Possible causes include:

1. An existing ArcSDE process is running and has hung.
2. There is an orphaned giomgr process that is no longer associated with a gsrvr process.
3. Another process is hung.
4. Another process is already using SDE's port.
5. The IPNODES file has been set up incorrectly.
6. IPv6 has been installed on the machine rather than IPv4.

Solution or Workaround

There are multiple possible solutions based on the cause of the issue.

  1. To check for existing SDE processes that are hung, try the following:

    a) Search for and remove any currently running SDE processes:

    ps -ef | grep sde


    b) Make a note of any SDE owned processes, and kill them:

    kill -9 <process id>


    c) Start SDE again:

    sdemon -o start -i <service name>


    d) If this still produces the error regarding zombie processes, try changing the syntax to the following:

    sdemon -o start -i <service name> -s <ip address>


    e) If this also produces the error, try changing the syntax to the following:

    sdemon -o start -i <service name> -s <hostname>


    f) If this also produces the error, try changing the syntax to the following:

    sdemon -o start -i <service name> -s <fully qualified domain name>

  2. To check for other processes running on the same port as SDE:

    a) Search for and remove any processes running on the same port as SDE:

         i) Find the service number:

    netstat -an

         ii) Find any other services running on the same port:

    netstat -an | grep <service number>


    b) Start SDE again (follow the same workflow as shown in Step 1c).
  3. To check for giomgr processes that have become orphaned, try the following:

    a) Check for orphaned giomgr processes:

    ps -ef | grep giomgr

    b) Make a note of any SDE owned processes, and kill them:

    kill -9 <process id>

    c) Start SDE again (follow the same workflow as shown in Step 1c).

    d) Check for orphaned gsrvr processes:

    ps -ef | grep gsrvr

    e) Make a note of any SDE owned processes, and kill them:

    kill -9 <process id>

    f) Start SDE again (follow the same workflow as shown in Step 1c).
  4. To verify that the IPNODE file is set up correctly:

    a) Edit the IPNODE system file and add the following line:

    <IPADDRESS> <MACHINENAME> loghost

    b) Start SDE again (follow the same workflow as shown in Step 1c).
  5. Check for a duplicate entry in the /etc/hosts file on the server or a separate service using the same port. These entries may conflict with each other, therefore, creating the problem.
  6. Try creating an environment variable SDEINSTANCE with the value of the service name.
  7. Verify that IPv6 is not set up on the machine.
  8. Run /usr/sbin/slibclean to kill any processes with load and use counts of zero (0).
  9. Try changing the port number that is used to start the service in the services.sde file and the system services file.
  10. Check for other installations of SDE as root and verify that none of them are causing the zombie process message by logging in as root and performing Steps 1 through 3 above.

Created: 6/11/2009
Last Modified: 5/3/2011

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