Knowledge Base - Technical Articles
Problem: MXD file size increases significantly with subsequent saves
| Article ID: | 33187 |
|---|---|
| Bug Id: | N/A |
| Software: | ArcGIS - ArcEditor 9.2 ArcGIS - ArcInfo 9.2 ArcGIS - ArcView 9.2 |
| Platforms: | Windows 2000, XP, 2003Server |
Description
File size may be less than one megabyte before the first save, 6.5 megabytes on the first save, 13 megabytes on the second and subsequent saves.
Cause
Whenever a geoprocessing tool is run in ArcCatalog, the results are stored in the Results tab in ArcToolbox which persists between ArcCatalog sessions. Conversely, when a geoprocessing tool is run in ArcMap, the results are stored in the Results tab in ArcToolbox and saved within the MXD.
The ArcCatalog Results tab cause MXDs to increase size. When ArcMap starts up, it loads the contents of ArcCatalog's ArcToolbox Results tab into ArcMap's ArcToolbox Results tab. Moreover, if an MXD is loaded into ArcMap, it also loads the Results tab stored in the MXD. When the MXD is saved, the contents of the Results tab are written to the MXD which includes the contents of the Results tab from ArcCatalog. All of the contents written to the MXD can be an issue because it is common for the Results tab to contain many geoprocessing results, potentially spanning many months, which may cause MXD 'bloat'.
Solution or Workaround
- Shut down ArcMap and open ArcCatalog.
- Go to ArcToolbox > Results Tab. In the Results tab, look for 'Current Session' and 'Previous Sessions'. If 'Previous Sessions' is not there, go to to step 4. If 'Previous Sessions' is there, go to step 3.
- Right-click 'Previous Sessions' > Remove All.
- Open the problematic MXD in ArcMap.
- Click File > Save As. Save the MXD to a new name.
- Check to see if the problem has been resolved. If it has been resolved, do not continue with the rest of the steps. If the problem persists, go to step 7.
- Go to ArcToolbox > Results Tab. In the Results tab, look for 'Current Session' and 'Previous Sessions'. Right-click 'Previous Sessions' > Remove All.
- Click File > Save As. Save the MXD to a new name.
Related Information
- WebHelp: An overview of geoprocessing history
- ArcCatalog crashes on shut down and/or displays the ArcToolbox Results tab
This article addresses two problems: - ArcCatalog crashes on shut down. - The ArcToolbox Results tab displays for several seconds or minutes when shutting down ArcCatalog or ArcMap, which may or may not result in a crash.
Created: 7/3/2007
Last Modified: 10/28/2009
Comments
By chaz6 - 06/25/2012 5:06 AM
The article needs to be updated.
It would be useful to have a maintenance tool as I have a large number of mxd files and to do this by hand for each one is very time consuming.
Rating:
By Anonymous - 09/10/2009 2:35 PM
The article needs to be updated.
This article needs to be updated for 9.3.1, which has a new setting for how long results are kept. http://webhelp.esri.com/arcgisdesktop/9.3/index.cfm?TopicName=Working_with_Results
Rating:
By maskari - 08/29/2012 10:32 AM
Other - See details below.
Try the method given in 38783 (HowTo: Save map documents in ArcGIS 10 to previous version of ArcGIS in batch). In the sample Python script given in that article, in the second to last line, change the code to match the software version you have.