Knowledge Base - Technical Articles


Technical Article   HowTo:  Format a table in Microsoft Access for use in ArcMap

Article ID: 30888
Software:  ArcGIS - ArcEditor 8.1, 8.1.2, 8.2, 8.3, 9.0, 9.1 ArcGIS - ArcInfo 8.0.1, 8.0.2, 8.1, 8.1.2, 8.2, 8.3, 9.0, 9.1 ArcGIS - ArcView 8.1, 8.1.2, 8.2, 8.3, 9.0, 9.1
Platforms: N/A

Summary

Instructions provided explain how to format a table in Microsoft Access for use in ArcMap. ArcMap is able to read the following table formats:

-dBase IV
-dBase V
-PRN
-CSV

Create these files in Microsoft Excel or Microsoft Access.

 For instructions on formatting tables in Microsoft Excel, see "HowTo:
Format a table in Microsoft Excel for use in ArcMap" in Related Information.


Procedure

To format a table in Microsoft Access that can be read in ArcMap:

  1. Start Microsoft Access.
  2. Click File > New > Blank Database > Save Database.

     Avoid path names that contain spaces. Do not start the name of the file with a number.

  3. Click File > Get External Data > Import table.

  4. Change 'Files of type' to the current table format. Browse to the file, click it once, and click Import.

  5. The import Text Wizard opens.

    -For text or CSV files, select 'Delimitted'.
    -For Excel files, select the appropriate sheet.

    Click Next.

  6. Select the appropriate delimiter that separates the fields for text or CSV files, or select whether to add column headings, or use existing column headings for Excel files and click Next.
  7. Select to store the data 'In a new table' and click Next.

  8. Field names and types are important when the table is brought into ArcMap. However, skip this step in the wizard because fields will be addressed after the import is complete.

  9. Select No for Indexed and click Next.

  10. If the table does not have a field with unique values, select "Let Access add primary key' and click Next.

  11. Name the table and click Finish to complete the table import.

     Table names must contain only letters, numbers, or underscores and must begin with a letter.

  12. Click the Design button to open the Design View dialog. -show me-

    Format the fields of your table in Access' Design View window.
    Microsoft Access Design View


  13. Format the fields in the Design View dialog following these guidelines:

    A. Field names require the following:

    -must contain only letters, numbers and underscores
    -must start with a letter
    -must not exceed ten characters
    -must be formatted as text

     For more information about formatting field and table names, see "What characters should not be used in ArcGIS for field names and table names?" in Related Information, below.

    B. Fields with Latitude and Longitude coordinate data require the following:

    -Data Type must be NUMBER
    -Field Size must be Double
    -Name the Latitude field 'LAT_Y', and the Longitude field 'LON_X' to help create XY Events

  14. Close the Design View dialog and save changes.

  15. Click File > Export.

  16. Change 'Save as Type:' to 'dBASE IV' and browse to an appropriate location and click Save.

Related Information


Created: 5/23/2006
Last Modified: 12/14/2009

If you would like to post a comment, please login