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Technical Article   Problem:  Issues with Windows XP SP2 and ArcGIS 9.0 products

Article ID: 28647
Bug Id: N/A
Software:  ArcGIS - ArcEditor 9.0 ArcGIS - ArcInfo 9.0 ArcGIS - ArcView 9.0 ArcGIS Engine Developer Kit 9.0 ArcGIS Server 9.0 ArcIMS 9.0 ArcInfo Workstation 9.0 ArcReader 9.0 ArcSDE 9.0
Platforms:  Windows XP

Description

The ArcGIS 9.0 products: ArcReader, ArcView, ArcEditor, ArcInfo Desktop, ArcInfo Workstation, ArcIMS, and ArcGIS Server, under Windows XP SP2 are certified with limitations.

Solution or Workaround

Several known limitations can be prevented or corrected by using the workarounds listed below:

ArcGIS Products

1. General errors due to specific installation scenarios of ArcGIS 9.0:

A. Installing ArcGIS 9.0 with Windows XP SP2 and an AMD64 chip, Regsvr32 is blocked and various .dlls fail to register causing error 1904.

Windows XP SP2 enables the Data Execution Prevention (DEP) feature that is embedded in some processors. The processors include: Intel Celeron-D, Xeon and AMD Athlon 64. Data execution prevention (DEP) is a set of hardware and software technologies that perform additional checks on memory to protect against malicious code exploits.

Workaround A: Disable DEP, install ArcGIS 9.0 and enable DEP after installation.

Workaround B: Remove Windows XP Service Pack 2 and install ArcGIS 9.0. Refer to the ESRI Knowledge Base article 28065 for more information.-show me-


Error Message
Installing ArcGIS products on a machine with a processor that supports data execution prevention (DEP), and Windows XP Service Pack 2 (SP2) results in a failed installation. This includes the AMD Athlon 64 Family processors, as well as newer Intel Xeon, Pentium 4, Pentium M or Centrino processors, and Celeron-D processors. The following error message or a similar error message is returned:

For ArcGIS 8.x:
"Error 1904. Module C:\arcgis\arcexe83\bin\AfuiCust.dll failed to register. HRESULT -2147023898. Contact your support personnel."

For ArcGIS 9.x:
"Error 1904: failed to register c:\Program Files\ArcGIS\Bin\xmlsupportui.dll" (or 3dsymbolsui.dll, GxRaster.dll). HRESULT -2147023898. Contact your support personnel."

Various other DLL's may fail to register during the process.
Cause
As of Windows XP SP2, Microsoft has enabled data execution prevention (DEP); a feature that is included in newer processor series from AMD and Intel. DEP is a set of hardware and software technologies that perform additional checks on memory to help protect against malicious code exploits. Intel refers to their version of DEP as XD or execution disabling bit. AMD refers to their version of DEP as the NX-bit or No Execute bit.
Solution or Workaround
Disable DEP in Windows XP SP2 using the steps below:

  Users with Intel processors may also need to disable the XD or execution disabling bit in their computer's CMOS/BIOS. Since each computer's CMOS is different, reference the computer's manual or contact the manufacturer of the computer for assistance with this step.



 WARNING: The instructions below include making changes to essential parts of your operating system. It is recommended that you backup your operating system and files, including the registry, before proceeding. Consult with a qualified computer systems professional, if necessary.

ESRI cannot guarantee results from incorrect modifications while following these instructions; therefore, use caution and proceed at your own risk.




  1. Verify the user is logged in as an Administrator for Windows XP.
  2. Go to Start > Control Panel and select the System applet.

     XP Home users may need to select the 'Classic View' link to be able to see the System applet.

  3. Click on the Advanced tab.
  4. Select the Settings button under Startup and Recovery.
  5. Beside 'To edit the startup options file manually, click Edit', click the Edit button. This opens the boot.ini file in Notepad.
  6. Locate the line that contains the following string:

    /NoExecute=OptIn

  7. Modify the string to change the switch to read:

    /NoExecute=AlwaysOff

  8. Save the file and reboot the machine.
  9. ArcGIS should install normally with no Error 1904 messages.
  10. After installation, change the boot.ini back to its original state, returning the added layer of security.


     The boot.ini file switches:
    /NoExecute=OptIn - Default setting. Only Windows system binaries are monitored by DEP.
    /NoExecute=OptOut - Enables DEP for all processes. Users can create a list of applications which are not monitored by DEP using the DEP configuration options listed in the System Control Panel applet.
    /NoExecute=AlwaysOn - Enables DEP for all processes. DEP is always applied, and exceptions lists are ignored and not available for users to apply.
    /NoExecute=AlwaysOff - Disables DEP.



B. Some users report installation issues with ArcGIS 9.0 when installing on Intel-based Windows XP machines that are pre-configured with an OEM installation of Windows XP SP2.

Please refer to ESRI Knowledge Base article 28065 for details on installing ArcGIS products with Microsoft Windows XP SP2 and the Data Execution Prevention (DEP) feature.

2. License manager issue:
The Windows XP SP2 enables by default, the Internet Connection Firewall (ICF). ICF restricts access to ports necessary for communication between ArcGIS and the license manager.

Workaround: Refer to and follow the procedure in ESRI Knowledge Base article 26134. -show me-

Summary
Instructions provided describe how to configure Windows XP's Internet Connection Firewall to work with the license manager. With the release of Windows XP Service Pack 2 (SP2), Microsoft has enabled its Internet Connection Firewall (ICF) by default. ICF restricts access to ports necessary for communication between ArcGIS and the license manager. The instructions provided below detail the steps to reopen the correct ports and allow ArcGIS to communicate with the license manager.

An alternative to this procedure would be to disable the ICF completely. Consult IT personnel before doing so.
Procedure
Machines running ArcGIS and Windows XP SP2 with ICF enabled, including the License Manager server, must run these steps while logged into the computer with administrative privileges. If the user account does not have administrative rights, contact a system administrator.

This article requires use of the Classic View in the Windows XP Control Panel.

  1. On the License Manager server, lock the ESRI (ArcGIS 8.x) or ArcGIS (ArcGIS 9.0) vendor daemon to a static port.
    -show me-

     The port specified in this step must be different than the port specified in step 6 below.

  2. Click Start > Control Panel > Network Connections on all machines with Windows XP Service Pack 2.

     These steps require the use of the Control Panel Classic View.

  3. Click Change Windows Firewall Settings in the left panel.
  4. Click the Exceptions tab.
  5. Click Add Port...
  6. Enter 'lmgrd' in the Name field. In the Port Number field enter the port number specified in the license file.
    -show me-
    Protocol should be set to TCP. Click OK.
  7. Click Add Port... again in the Exceptions dialog box and follow the same procedure used in the previous step, entering 'ArcGIS' at version 9.x or 'ESRI' at version 8.x in the Name field, and the number added to the license file in steps 1-7 as the Port Number (for example, 1234).
  8. Click OK to close and enable the Internet Connection Firewall.


The license manager issue affects both 8.x and 9.x license managers and therefore all license managed products are affected. The products include:
-ArcGIS Desktop 8.x and 9.x
-Concurrent Use ArcInfo Workstation 8.x and 9.x
-ArcSDE 8.x
-ArcIMS ArcMap Server 4.x.

ArcGIS Desktop: ArcInfo, ArcEditor & ArcView

1. Problems using the Animation Manager in 3D Analysts’ ArcScene and ArcGlobe Application in ArcGIS 9.0:

A. An error occurs in the ArcGlobe and ArcScene applications if the Animation Manager is opened before any animation tracks were created.

Steps to reproduce the problem:
1. Open ArcGlobe or ArcScene.
2. Add data, if none are present.
3. Invoke the Animation toolbar (right-click on the empty toolbar area and in the dropdown menu select 'Animations').
4. Open the 'Animation Manager' dialog box (Animations toolbar -> Animation Manager).
5. Application crashes in 'comctl32.dll'

Workaround: Download ArcGIS 9.0 Service Pack 3 (SP3). If this is not available to you, create animation tracks before opening the 'Animation Manager' dialog box.

B. An error occurs in the ArcGlobe and ArcScene applications when the 'Close' button is pressed on the Animation Track Binding dialog box.

Steps to reproduce the problem:
1. Open ArcGlobe or ArcScene.
2. Add any data, if none is present.
3. Invoke the Animation toolbar (right-click on the empty toolbar area and in the dropdown menu select 'Animations').
4. Click on the 'Capture View to an Animation' tool.
5. Open the 'Animation Manager' dialog box (Animations toolbar -> Animation Manager).
6. Go to the 'Tracks' property page.
7. Click on the 'Binding' button to bring up the 'Binding of Animation Track' dialog box.
8. Close the 'Binding of Animation Track' dialog box.
9. Application errors in 'comctl32.dll'

Workaround: Download ArcGIS 9.0 Service Pack 3 (SP3).

2. Some random ArcGIS 9.0 problems seem to relate to incomplete or corrupt installs of Windows or the Service Pack. In these rare cases, repairing the system files solved the issues.

3. Script tools based on AMLs do not run after installing Windows XP SP2. This problem persists even after running the RunAMLasExecutable.reg. One of the following scenarios will occur when an AML script is run:

A. An empty DOS window appears but nothing happens and the script does not run.
B. The progress dialog box indicates that the script is running but nothing happens and the script does not run.

Workaround: complete the following steps:

1. Find the RegisterAMLasExecutable.reg file (typically found at C:\Program Files\ArcGIS\ArcToolbox\Scripts)
2. Right-click and edit this file.
3. In the line below, replace arc.exe with the full path to arc.exe: @="arc.exe \"&run\" %0 %*"

For example, if the path to arc.exe is C:\arcgis\arcexe9x\bin\arc.exe, the new line will look as follows: @="\"C:\\arcgis\\arcexe9x\\bin\\arc.exe\" \"&run\" %0 %*"

 The \ is an escape character that must be inserted before all quotation marks (") and slashes (\).

When the changes above are made, double-click the file. When asked if you want to add the information to the registry, click OK. When informed the information was successfully added, click OK.

ArcGIS Server

Windows XP SP2 installs and enables a firewall called Windows Firewall. The default settings in the firewall cause ArcGIS Server to block all incoming connections. To correct this, add exceptions in the Windows Firewall. For instructions on how to do this, refer to - ESRI Knowledge Base article 27798. -show me-


Summary
Instructions provided describe how to configure Windows XP SP2 Firewall to work with ArcGIS Server. Windows XP Service Pack 2 must be installed to complete the procedure below, which outlines the steps required to configure Windows Firewall for ArcGIS Server.
Procedure
When upgrading Windows XP with Service Pack 2, a firewall titled 'Windows Firewall' is installed and enabled. The default settings for the firewall cause Windows XP to block all incoming connections for ArcGIS Server. To work around this, create exceptions for port 80, port 135, ArcSOM.exe and ArcSOC.exe in the Windows Firewall settings.

  1. Navigate to Windows Firewall.

    Start > Settings > Control Panel > Windows Firewall

     The firewall is 'On' by default, the 'Recommended' setting.

  2. Click on the Exceptions tab.
  3. Click 'Add Port'.
  4. Add the following information:

    Name: Web Port (http)
    Port Number: 80
    Type: TCP

    Click OK.
  5. To add port 135, click 'Add Port'.
  6. Add the following information:

    Name: DCOM (ArcGIS Server)
    Port Number: 135
    Type: TCP

    Click OK.
  7. Click 'Add Program' to add an exception for ArcSOM.exe.
  8. Click 'Browse' and navigate to:
    <ArcGIS Install Directory>\bin\ArcSOM.exe
    For example: C:\Program Files\ArcGIS\bin\ArcSOM.exe

    Click OK.

  9. Click Add Program to add an exception for ArcSOC.exe.
  10. Click 'Browse' and navigate to:
    <ArcGIS Install Directory>\bin\ArcSOC.exe
    For example: C:\Program Files\ArcGIS\bin\ArcSOC.exe

    Click OK.

  11. The ports and programs entered should now appear in the list of Programs and Services. Verify that check marks appear next to each component.
  12. Close Windows Firewall.

ArcIMS
Requires ArcIMS 9.0 Service Pack 2


1. Windows XP SP2 users may encounter the following issues with ArcIMS 9.0 and ArcIMS 9.0 Service Pack 1:

A. CQ00249542 - Service Administrator: Cannot create any ArcIMS services.
B. CQ00249545 - Java Custom and Java Standard Viewers: Identify results list has display problems.
C. CQ00249551 - JSP Viewer: Legend frame doesn't refresh when a service is added.

Workaround - Download ArcGIS 9.0 Service Pack 3 (SP3).

2. XML declaration appears only at the beginning of a document in ArcIMS 9.0 when creating feature, metadata, or image services with Windows XP SP2.

Workaround - Refer to ESRI Knowledge Base article 28313 for more information on this issue. -show me-


Description
When trying to create image, feature, or metadata services using the ArcIMS Service Administrator (esriadmin) on Windows XP Service Pack 2 (SP2), an error message is returned and the services are not created. The following error is returned:

"XML declaration may only appear at the beginning of the document"

This problem can occur when:

- ArcIMS 9.0, without Service Pack 2, is installed on Windows XP SP2.
- ArcIMS 9.0, with Service Pack 2, is installed on Windows XP SP2 and the servlet engine is Tomcat.
Cause
The arcims_jconnect.jar file that is being used by Service Administrator is not the most current version.
Workaround
This problem is resolved with an updated version of arcims_jconnect.jar that is installed with ArcIMS 9.0 Service Pack 2. Complete the following steps to verify the file is up to date:

If ArcIMS 9.0 Service Pack 2 has not been installed, install it. A link to ArcIMS 9.0 Service Pack 2 is provided by way of the Related Information section below.

If the problem still occurs and ArcIMS 9.0 Service Pack 2 has been installed on a machine that is using Tomcat as a servlet engine, perform the following:

1. Stop the Tomcat service.
2. Navigate to <Tomcat Install Directory>\webapps and delete the \esriadmin folder.
3. Start the Tomcat service.

 The \esriadmin folder is re-created with the most current files.




3. Legend frames do not refresh in ArcIMS 9.0 projects with Windows XP SP2.

Workaround - Refer to ESRI Knowledge Base article 28315 for more information on this issue. -show me-

Description
The legend feature works on first load of jspviewer with the SantaClara service; however, when loading a different service and clicking on the legend tool, the following javascript error occurs:

"Access is denied"

This problem can occur when:

- ArcIMS 9.0, without Service Pack 2, is installed on Windows XP Service Pack 2 (SP2).
- ArcIMS 9.0, with Service Pack 2, is installed on Windows XP SP2 and the servlet engine is Tomcat.
Cause
The arcims_jconnect.jar file that is being used by the jspviewer sample is not the most current version.
Workaround
This problem is resolved with an updated version of arcims_jconnect.jar that is installed with ArcIMS 9.0 Service Pack 2. Complete the following steps to verify the file is up-to-date.

If ArcIMS 9.0 Service Pack 2 has not been installed, install it. A link to ArcIMS 9.0 Service Pack 2, can be found in the Related Information section below.

Download ArcIMS Service Pack 2 by navigating to ESRI Online Support > Downloads > Patches & Service Packs > ArcIMS by way of the Related Information section below.

If the problem still occurs and ArcIMS Service Pack 2 has been installed on a machine that is using Tomcat as a servlet engine, perform the following:

1. Stop the Tomcat service.
2. Navigate to <Tomcat Install Directory>\webapps and delete the \jspviewer folder.
3. Start the Tomcat service.

 The \jspviewer folder is re-created with the most current files.




4. When installing Windows XP SP2, it installs and enables a firewall called Windows Firewall. The default settings in the firewall cause ArcIMS 9.0 to block all incoming connections. To correct this, add exceptions in the Windows Firewall. For instructions on how to do this, refer to - ESRI Knowledge Base article 27854. -show me-

Summary
Instructions provided describe how to configure Windows XP SP2 Firewall to work with ArcIMS. Windows XP Service Pack 2 must be installed to complete the procedure below, which outlines the steps required to configure Windows Firewall for ArcIMS.
Procedure
When upgrading Windows XP with Service Pack 2, a firewall titled 'Windows Firewall' is installed and enabled. The default settings for the firewall cause Windows XP to block all incoming connections for ArcIMS. The workaround below creates exceptions for the ports used by the Web server, Servlet Engine and ArcIMS in the Windows Firewall settings.

  1. Navigate to Windows Firewall.

    Start > Settings > Control Panel > Windows Firewall

     The firewall is 'On' by default, the 'Recommended' setting.

  2. Click on the Exceptions tab.
  3. Click 'Add Port'.
  4. Add the following information:

    Name: Web Port (http)
    Port Number: 80
    Type: TCP

      If this is a single machine ArcIMS installation where all components such as, Web server and Servlet Engine are on the same physical machine, skip to step 7.

  5. If ArcIMS is deployed in a distributed or multiple machine configuration, the appropriate ports need to be opened by repeating steps 3 and 4 above, as well as the following additional steps:

    Ports and settings for ArcIMS:

    Name: ArcIMS AppServer Connector Port
    Port Number: 5300
    Type: TCP

    Name: ArcIMS AppServer Register Port
    Port Number: 5353
    Type: TCP

    Name: Monitor Listener Port
    Port Number: 5050
    Type: TCP

    Name: Tasker Listener Port
    Port Number: 5060
    Type: TCP
  6. If ArcIMS is deployed in a distributed or multiple machine configuration, and the Spatial Server is installed on a Windows XP SP2 machine, perform the following steps:

    A. Click 'Add Program'.
    B. Click 'Browse' and navigate to:
    <ArcIMS Directory>\Server\bin\aimsserver.exe
    For example: C:\Program Files\ArcGIS\ArcIMS\Server\bin\aimsserver.exe
    C. Click 'OK'.
    D. Verify that the exception for the Monitor Listener port has been created as shown in step 5 above.
  7. The ports and programs entered should appear in the list of Programs and Services. Verify that check marks appear next to each component.
  8. Close Windows Firewall.

ArcSDE 9.0

In general, database vendors do not regard Windows XP as an operating system for production databases. For that reason, we do not test or otherwise certify the ArcSDE 9.0 application server with the Windows XP operating system.

Direct connect is certified on XP and other versions of Windows as part of the ArcGIS 9.0 and ArcIMS 9.0 certification process.



Related Information


Created: 2/15/2005
Last Modified: 1/29/2010

Article Rating: (2)
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Comments

By Anonymous - 11/15/2005 12:05 AM

THE ArcGIS cant find the server hostname in network database Haw I can slove this problem ?

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By Anonymous - 11/04/2005 4:28 PM

You mention under ArcGis Products 1B that some OEM versions of XP SP2 have problems, and that these problems are currently being worked on. However, a solution exists elsewhere on your site. Perhaps you should update this page so people don't give up hope too soon. See http://support.esri.com/index.cfm?fa=knowledgebase.techarticles.articleShow&d=28065 Cheers, J

By Anonymous - 05/02/2005 5:00 PM

Is this article applicable to 8.3 installs for the same reason? I received the same message. Please state in the article header if this applies to versions earlier than 9.0

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