Knowledge Base - Technical Articles


Technical Article   Error:  Failed to update System registry. Please use REGEDIT

Article ID: 17843
Software:  ArcGIS - ArcEditor 8.1 ArcGIS - ArcInfo 8.1 ArcGIS - ArcView 8.1
Platforms:  Windows NT 4.0, 2000

Error Message

Opening ArcMap or ArcScene produces the error:

"Failed to update System registry. Please use REGEDIT"

Cause

The user account into which you are logged lacks adequate permission to update some registry keys.

Solution or Workaround

Although this message has not been found to affect functionality, your system administrator can grant your user account FULL CONTROL to the following registry keys. -show me-


Summary
Contained in this document are the steps necessary to modify permissions to keys in the Windows registry.
Procedure


 WARNING: The instructions below include making changes to essential parts of your operating system. It is recommended that you backup your operating system and files, including the registry, before proceeding. Consult with a qualified computer systems professional, if necessary.

ESRI cannot guarantee results from incorrect modifications while following these instructions. Therefore, use caution and proceed at your own risk.



Please visit the link in the Related Information section prior to any registry modifications.

  1. Click Start > Run. Type 'regedt32'.
  2. Browse to the key/folder to be modified and highlight it.
  3. Windows NT and 2000 - Click Security > Permissions.

    Windows XP - Click Edit > Permissions

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID

HKEY_CLASSES_ROOT\esriCore.MxDocument
HKEY_CLASSES_ROOT\esriCore.SxDocument



  The HKEY_CLASSES_ROOT\esriCore.MxDocument is created by ArcMap. You must run ArcMap as an administrator to create the key before changing its permissions.


HKEY_CLASSES_ROOT\esriCore.SxDocument is created by ArcCatalog. ArcCatalog must be run as an administrator to create the key before changing permissions.


Related Information


Created: 4/9/2001
Last Modified: 11/20/2003

Article Rating: (3)
If you would like to post a comment, please login

Comments

By Anonymous - 03/05/2003 3:11 PM

In ArcGIS 8.2, on WinXP, the error appears but there NO is HKCR\esriCore.MxDocument key and several SxDocument.... keys (but no SxDocument key alone). Which one to fix? Thanks

Rating:

By Anonymous - 02/14/2003 12:58 AM

Rating:

By Anonymous - 01/22/2003 3:52 AM

'this message has not been found to affect functionality' surprises me.

Rating: