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Technical Article   Error:  FLEXlm Error: The desired vendor daemon is down

Article ID: 12680
Software:  ArcGIS - ArcEditor 8.3, 8.1, 8.1.2, 8.2, 9.0, 9.1, 9.2, 9.3, 9.3.1 ArcGIS - ArcInfo 8.2, 9.0, 8.0.1, 8.0.2, 8.1, 8.1.2, 8.3, 9.1, 9.2, 9.3, 9.3.1 ArcGIS - ArcView 8.3, 8.1, 8.1.2, 8.2, 9.0, 9.1, 9.2, 9.3, 9.3.1 ArcInfo Workstation 7.1.1, 7.1.2, 7.2.1
Platforms:  Windows NT 4.0, 2000, XP, 2003Server, Vista

Error Message

The following error occurs when attempting to start ArcInfo:

FLEXlm Error: The desired vendor daemon is down
1) Check the lmgrd log file, or 2) Try lmreread
Feature: ARC/INFO
Vendor:Host: ESRI : server1
License path: @server1;@server1;d:\arcexe80\sysgen -
\license.dat
FLEXlm error: -97,380. System Error: 10061 ""
For further information, refer to the FLEXlm End User Manual,
available at "www.globetrotter.com".
Program not run.

Cause

ArcInfo will not start until it is able to connect to and checkout a license from a license server.

Solution or Workaround

These solutions are listed from the most common to the least common:

  • Make sure the Sentinel Key (Hardware Dongle) is attached and responding correctly. -show me-

    Summary
    The Sentinel Key is a parallel or USB port hardware dongle that provides a unique number used in the generation of the users' licenses. The Sentinel Key returns its number only when the Sentinel Key and the Sentinel Key Driver are communicating properly.
    Procedure
    • To verify the Sentinel Key and Sentinel Driver are installed and running correctly, click Start > Programs > ArcGIS > License Manager > Display Hardware Key Status. A window appears with the message:

      The Sentinel driver is installed and running.
      

      Sentinel Driver Version: PD-5.39

      ESRI_SENTINEL_KEY=37123456

      If this message appears, the Sentinel Driver and Key are functioning properly.
    • If no window, a blank window, or a window with the message

      The SuperPro driver appears to be installed and running.
      
      However, the hardware key does not appear to be plugged into a parallel port on this system.

      appears, verify that the key is plugged securely into the back of the computer and remove any devices, such as Zip drive, printer, or other Sentinel Keys that are plugged into the back of the key. After removing these devices, recheck the Sentinel Key status to see if the key is now recognized.
    • ArcGIS 8.x uses Sentinel Key Driver version PD 5.38 or above. Download and install the latest version of the sentinel driver.
      -show me-
    • If the Sentinel Driver is version PPD 5.38 or later and the Sentinel Key is conflicting with another device, one option is to install a second parallel port card to add a second parallel port or to use a USB key. Make sure that the ESRI hardware key is attached to the primary parallel port.
    • If multiple hardware keys are plugged into the parallel port, try placing the ESRI Sentinel Key as the first in the chain and recheck the Sentinel Key status.
    • If a printer is plugged into the back of the parallel Sentinel Key, turn the printer on and recheck the Sentinel Key status.
    • If there are no devices attached to the parallel Sentinel Key, and the Display Hardware Key Status window still doesn't return the Sentinel Key number and driver version, try printing through the parallel port without the Sentinel Key attached. If it does not print, the parallel port is misconfigured or bad. Contact a System Administrator for help to correct the parallel port communication.
    • A final test of the key would be to install the key and the License Manager on another Windows system. Once the License Manager has been installed, run Display Hardware Key Status. If the Sentinel Key number is not displayed, the Sentinel key may be defective. Contact Customer Service to exchange your key for a new one. Once the new key is received, contact Customer Service for a new license file based on the new Sentinel Key's number.
  • Make sure you are using the latest License Manager. You may need to reinstall the License Manger to solve the error.
  • Make sure the information in the License File is accurate. -show me-

    Summary
    The ArcGIS License Manager requires that the license file information be appropriate for the system and that it matches the information sent from the ESRI Keycode Department.
    Procedure
    1. The license files for ArcGIS are located in C:\Program Files\ESRI\License and end with a '.lic' file extension. The Arcinfo.lic file looks similar to this:

      SERVER server1 ESRI_SENTINEL_KEY=37123456 27005
      
      VENDOR ESRI
      FEATURE ARC/INFO ESRI 8.01 01-jan-00 1 3BFE602241F669DB9349 \
      vendor_info="8DCZFL5B5R6D6RH8L023" ck=15

    2. The second entry on the SERVER line is the hostname of your computer. Make sure the hostname entry matches the actual hostname of the system (see step 1). The hostname entry is not tied to your keycode, and may be changed as long as it matches the hostname of the system that runs the license manager.
    3. The third entry on the SERVER line is the Sentinel Key number. This number should match the number returned by running Start > Programs > ArcGIS > License Manager > Display Hardware Key Status. Occasionally, the number printed on the Sentinel Key does not match the number returned by checking 'Display Hardware Key Status'. In this case, use the number returned by 'Display Hardware Key Status' to request new licenses.
      Notice this number always starts with a '3'. For example, if the e-mail tool used is Microsoft Outlook with Microsoft Word as the e-mail editor, all instances of '=3' will be stripped from the license file(s), as '=3' is a special Microsoft Word programming code. In such case, edit the license file(s) to restore the '=3'.
    4. The last item on each FEATURE line is the checksum number. The checksum number can also be stripped of a '=3'. The entry should contain 'ck=' followed by a number. If the equal sign is missing, the number three will also be missing. In such case, edit the license file(s) to restore the '=3' in the checksum number.

Related Information

  • FLEXlm Error: -15 Cannot connect to license server
    The following error message displays when starting an ArcGIS Desktop application: "FLEXlm Error: Cannot connect to license server. The server (lmgrd) has not been started yet, or the wrong port@host or license file is being used, or the port or...

Created: 6/19/2000
Last Modified: 5/3/2011

Article Rating: (2)
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Comments

By Raira - 07/16/2013 1:17 AM

The article is incorrect or the solution didn’t work.

please this is not helping me at all. i'm using arcgis 9.3 and i'v no idea where the sentinel key drive is because i'm not using any external drives to start up the arcgis 9.3. so really pleaseeee i need you guyz help. thanks

By Anonymous - 09/18/2008 11:04 AM

The article contains a dead link.

The link to the Rainbow Sentinel Download goes to Rainbow.com which is apparently a clothing site.

Rating:

By Anonymous - 08/17/2004 3:09 PM

This does not help me at all

Rating: