English

Esri Business Analyst GP Tools for Server General Maintenance Patch

Summary

This patch addresses stability issues when executing ArcGIS Server geoprocessing services that leverage Esri Business Analyst tools.

Description

Introduction

Esri® announces Esri Business Analyst GP Tools for Server General Maintenance Patch. This patch improves the stability of geoprocessing services that leverage tools from the Esri Business Analyst toolbox. It deals specifically with the issues listed below under Issues Addressed with this Patch.


Issues Addressed with this patch


  • BUG-000090404 - "ERROR 000816: The tool is not valid" periodically results from running a geoprocessing service containing one or more Business Analyst tools, with Esri Business Analyst GP Tools for Server installed.

Installing this patch on Windows

Installation Steps:

Esri Business Analyst GP Tools for Server must be installed before installing this patch.

  1. Download the appropriate file for your environment to a location other than your installation location.

  2. Version 10.3.1   Checksum (Md5)
         
          Esri Business Analyst GP Tools for Server ArcGIS-1031-BAGP-GM-Patch.msp 52B5571F8FEAB38DDAEA737CB4F0D80F
         
    Version 10.3    
         
          Esri Business Analyst GP Tools for Server ArcGIS-103-BAGP-GM-Patch.msp C9A71201EEFF04A7D1061C58D56F9CB2
         

  3. Make sure you have write access to your installation location.

  4. Double-click ArcGIS-<Version>-BAGP-GM-Patch.msp to start the setup process.

    NOTE: If double clicking on the MSP file does not start the setup installation, you can start the setup installation manually by using the following command:

    msiexec.exe /p [location of Patch]\ArcGIS-<Version>-BA-GU-Patch.msp

Patch Updates

Check the Patches and Service Packs page periodically for the availability of additional patches. New information about this patch will be posted here.

Getting Help

Domestic sites, please contact Esri Technical Support at 1-888-377-4575, if you have any difficulty installing this patch. International sites, please contact your local Esri software distributor.