English

Esri Maps for MicroStrategy Mobile iOS Client Framework 2.0 Patch 1

Summary

This patch for Esri Maps for MicroStrategy Mobile iOS client framework offers support for MicroStrategy Mobile for iOS SDK 9.5.

Description

Introduction

Esri® announces the Esri Maps for MicroStrategy Mobile iOS Client Framework 2.0 Patch 1. This patch provides an update to the Esri Maps for MicroStrategy Mobile iOS client framework to support MicroStrategy Mobile 9.5. After applying the patch, you must re-compile your app using this new Esri Maps for MicroStrategy Mobile iOS client framework, MicroStrategy Mobile SDK for iOS 9.5, iOS SDK 8, and Xcode 6.0. It deals specifically with the issues listed below under Issues Addressed with this Patch.

Issues Addressed with this patch


  • BUG-000042272 - Create Mobile patch for 2.0 release to support MicroStrategy SDK for iOS 9.5.

Files Installed in this patch


    readme.txt
    /em4mm/config.xml
    /em4mm/Esri Maps for MicroStrategy Mobile Administrator Guide.pdf
    /em4mm/LICENSE-Cordova
    /em4mm/NOTICE-Cordova
    /em4mm/version.txt
    /em4mm/vis.plist
    /em4mm/Em4Mstr.framework/Em4Mstr
    /em4mm/Em4Mstr.framework/Headers/Em4Mstr/Em4Mstr.h
    /em4mm/Em4Mstr.framework/Headers/Em4Mstr/Em4MstrAppDelegate.h
    /em4mm/Em4Mstr.framework/Resources/Em4Mstr.bundle/Info.plist
    /em4mm/Em4Mstr.framework/Resources/Em4Mstr.bundle/en.lproj/Em4Mstr.strings

Download the file to a location other than your Esri Maps for MicroStrategy Mobile location.

    Checksum (Md5)
Esri Maps for Microstrategy Mobile em4mm_iOSClient_2.0_patch_1.zip BCD4F9EE5E5E91366D83C1B42ABB0839
     

Installing this patch on MAC

Installation Steps:

Before you start, make sure you have write access to the Esri Maps for MicroStrategy Mobile 2.0 install location.

Changes to prerequisites:

  1. Ensure that you have satisfied all the requirements in the Developer prerequisites section of Esri Maps for MicroStrategy Mobile Administrator's Guide (using the new "Changes to prerequisites" mentioned above).

  2. Extract the contents of the 9.5 MicroStrategy Mobile SDK from the DMG image on your local hard drive:
    1. Unzip the .dmg.zip file.
    2. Double-click the .dmg file.
    3. Click Agree. MicroStrategy Mobile SDK should appear on the desktop.

  3. Download the em4mm_iOSClient_2.0_patch_1.zip.

  4. Copy the em4mm directory from the patch.

  5. IF:
    • You have not yet installed Esri Maps for MicroStrategy 2.0, place the em4mm directory in your installation location, or
    • You have an existing installation of Esri Maps for MicroStrategy 2.0, replace the existing <EM4MMInstall> directory with the em4mm directory from the patch.

Follow the instructions for compiling the app and creating the app archive, starting at step 3 on page 8 of the Esri Maps for MicroStrategy Mobile Administrator's Guide. A PDF of this guide is also included in the patch.

Notes:

  • The minimum requirement for installing this patch is Esri Maps for MicroStrategy version 2.0; specifically, the server plug-in must be installed on both the MicroStrategy Web server and the MicroStrategy Mobile server.
  • The prerequisites listed in the Esri Maps for MicroStrategy Mobile Administrator's Guide (both online and in the PDF included in this patch) are out of date. For current information about supported environments, see "Changes to prerequisites" above.

Patch Updates

Check the Patches and Service Packs page periodically for the availability of additional patches. New information about this patch will be posted here.

Getting Help

Domestic sites, please contact Esri Technical Support at 1-888-377-4575, if you have any difficulty installing this patch. International sites, please contact your local Esri software distributor.