English

ArcGIS 9.3.1 SP2 QIP (Desktop, Engine, Server) Geometric Network Reconcile Patch

Summary

This patch addresses an issue that may occur during reconcile of a geometric network where a user encounters the following error: “The version could not be reconciled. Invalid network element id”. This error is encountered after installation of the ArcGIS 9.3.1 SP2 QIP (Desktop, Engine, Server) Geodatabase Patch. Esri recommends that all sites that have installed the ArcGIS 9.3.1 SP2 QIP (Desktop, Engine, Server) Geodatabase Patch and are seeing the before mentioned error install this patch.

Description

Introduction

Esri® announces the ArcGIS 9.3.1 SP2 QIP (Desktop, Engine, Server) Geometric Network Reconcile Patch. This patch addresses an issue that may occur during reconcile of a geometric network where a user encounters the following error:

"The version could not be reconciled."
"Invalid network element id."

This error is encountered after installation of the ArcGIS 9.3.1 SP2 QIP (Desktop, Engine, Server) Geodatabase Patch. Reconciling the version with previous ArcGIS 9.3.1 patches does not produce the error. Esri recommends that all sites that have installed the ArcGIS 9.3.1 SP2 QIP (Desktop, Engine, Server) Geodatabase Patch and are seeing the before mentioned error install this patch. It deals specifically with the issues listed below under Issues Addressed with this Patch.

Issues Addressed with this Patch


  • NIM087777 - Reconciling a user version gets an "Invalid network element id" error after installing ArcGIS Desktop 9.3.1 SP2 QIP's latest Geodatabase Patch. For more information regarding this issue, please see Technical Article 40827.

Files Installed in this Patch


    Under the Windows <ArcGIS Product Installation Directory>\bin folder:

      GdbNet.dll

Installing this Patch on Windows


Installation Notes:

ArcGIS Desktop 9.3.1 Service Pack 2 Quality Improvement Patch and the ArcGIS 9.3.1 SP2 QIP (Desktop, Engine, Server) Geodatabase Patch must be installed before you can install this patch.


  1. Download the appropriate file to a location other than your ArcGIS installation location.

  2.     Checksum
    ArcGIS (Desktop, Engine, Server) ArcGIS-931SP2QIP-DTES-GNR-Patch.exe E42B9D397D14D8CDA3A11B2A241A0322

  3. Make sure you have write access to your ArcGIS installation location.


  4. For ArcGIS Server GIS Services Only: Open the Services Management Console> Control Panel > Administrative Tools > Services. Stop the ArcGIS Server Object Manager and ArcGIS Server SOC Monitor services.

    For ArcGIS Server Java Only: Open the Services Management Console> Control Panel > Administrative Tools > Services. Stop the ArcGIS Server Object Manager; ArcGIS Server SOC Monitor and ArcGIS Server Manager services.


  5. Double-click ArcGIS-931SP2QIP-DTES-GNR-Patch.exe to start the install process.

  6. When Setup starts, follow the instructions on your screen.


  7. For ArcGIS Server GIS Services Only: Open the Services Management Console> Control Panel > Administrative Tools > Services. Start the ArcGIS Server Object Manager and ArcGIS Server SOC Monitor services.

    For ArcGIS Server Java Only: Open the Services Management Console> Control Panel > Administrative Tools > Services. Start the ArcGIS Server Object Manager; ArcGIS Server SOC Monitor and ArcGIS Server Manager services.

Patch Updates

Check the Patches and Service Packs page periodically for the availability of additional patches. New information about this Patch will be posted here.

March 29, 2013: Changed typo in list of files installed from GdbNetwork.dll to GdbNet.dll.

How to identify which Patch is installed


Windows

    To find out what ArcGIS products are currently installed on your machine, download the PatchFinder.exe utility and run it from your local machine.

Linux / Unix

    To find out what ArcGIS products are currently installed on your machine, download and extract the PatchFinder utility and run it from your local machine.

Getting Help

Domestic sites, please contact Esri Technical Support at 1-888-377-4575, if you have any difficulty installing this Patch. International sites, please contact your local Esri software distributor.