English

Military Overlay Editor 9.2 Service Pack 1 for Linux

Summary

ESRI announces Military Overlay Editor (MOLE) 9.2 Service Pack 1 for Linux. This service pack contains several improvements and maintenance fixes for MOLE 9.2 on Linux.

Description

Introduction


We recommend that all MOLE 9.2 customers download and install this service pack, at their earliest convenience, to ensure the highest quality experience when working MOLE 9.2 on Linux.

Issues Addressed with this Service Pack


  • Improvements were made to the API to correct the slow loading of FEGraphicFactory. This change also reduces the time it takes in the user interface for MOLE layers to open in ArcGIS applications such as ArcMap and ArcGlobe.
  • In some cases, after performing a UTM projection on an incoming geometry, MOLE was not checking to see if the projected shape was valid or was instead empty. In cases where the incoming geometry was outside the coordinate system of the display, the projected function was returning an empty geometry, which caused unpredictable results when MOLE tried to use that empty geometry to construct a graphic. This issue has been addressed.
  • NIM032925 In several MOLE interfaces, you would receive a Bad Variable Type exception. This issue has been addressed.
  • NIM032961 Mine fields with Symbol ID code G*MPOFD--****X - would not draw correctly. This issue has been addressed.
  • NIM032960 Wire obstacles with Symbol ID code G*MPOWS--****X would not draw correctly. This issue has been addressed.
  • Changes were made to moleCore, so if you’ve customized moleCore, be sure to save a backup before you install this service pack. Note that customizing moleCore is not recommended.

Files Installed with this Service Pack


The service pack installs the following files to the ArcGIS installation directory.

    moleCore.gdb
    moleControls9.ocx
    DracoCore.dll
    Libdracocore.so
    moleclassextensions2.dll
    libmoleclassextensions2.so
    molecore2.dll
    molecorerules2.dll
    libmolecorerules2.so
    MoleCore2.dll
    MoleDDD.dll
    libmoleddd.so
    MoleTacticalRenders2.dll
    libMOLETacticalRenders2.so
    MoleUICommands.dll
    libmolesdk.so
    esrimole.olb
    libesrimole.so
    esrimole.tlh

Installing the Service Pack


ArcGIS 9.2 and MOLE 9.2 must be installed before you can install this service pack.
  1. Make sure you have write access to your ArcGIS installation directory and that no one is accessing it.
  2. Download the file in the Downloads section below to a location other than the ArcGIS installation directory.
  3. Extract the .tar archive into an empty temporary directory.
  4. Run the apply patch script.
  5. Follow the on-screen instructions.

NOTE: If you have installed client setups from a shared Network Administrative ArcGIS Desktop setup, this Service Pack must be applied to all client installations.

Service Pack Updates
Check the Online Support Center periodically for the availability of additional patches.

Getting Help
Domestic sites, contact ESRI Technical Support at 909.793.3774 if you have any difficulty installing this service pack. International sites, contact your local ESRI software distributor.

Download

Supporting Files :