English

ArcGIS 9.2 Patch for the Sun Solaris X11 Security issue

Summary

This patch resolves an ArcGIS 9.2 compatibility issue when running ArcGIS, ArcIMS or ArcInfo Workstation on a Solaris 9 or 10 machine which has the "Sun Solaris X11 Security Patch ID (Solaris 9: 112785-62) (Solaris 10: 119059-27)" installed.

Description

Introduction

ESRI® announces the ArcGIS 9.2 Patch for the Sun Solaris X11 Security issue. This patch resolves an ArcGIS 9.2 compatibility issue when running ArcGIS, ArcIMS or ArcInfo Workstation on a Solaris 9 or 10 machine which has the "Sun Solaris X11 Security Patch ID (Solaris 9: 112785-62) (Solaris 10: 119059-27)" installed. We recommend that all who plan to run ArcGIS 9.2 on a Solaris 9 or 10 machine with the Security Patch installed, download and install this Patch at their earliest convenience to ensure the highest quality experience when working with ArcGIS 9.2. It deals specifically with the issues listed below under Issues Addressed with this Patch.

Issues Addressed with this Patch


    Description: Customers who have installed the Sun Solaris X11 Patch ID (Solaris 9: 112785-62) (Solaris 10: 119059-27) will encounter the following problems: (Higher Versions of the Sun patches listed above may also cause these failures)

    • ArcReader does not open 2D or 3D published maps (.pmf).
    • ArcGIS Server services do not start.
    • ArcIMS ArcMap services do not start.
    • ArcInfo Workstation ArcPlot text commands return a FATAL ERROR

Files Installed in this Patch


A complete list of the Files installed in this patch is available here.

Installing the Patch

ArcGIS or ArcIMS 9.2 must be installed before you can install this Patch. This patch can be applied to ArcGIS Server, ArcGIS Engine, ArcGIS Reader, ArcInfo Workstation or ArcIMS MapServer for Sun Solaris.

    1. Make sure you have write permission to your ArcGIS or ArcIMS installation location, and that no one is using ArcGIS or ArcIMS.


    2. Download the appropriate file to a location other than the installation location:

    3. Extract the specified tar file by typing:

        % tar -xvf <product>92-solaris-patch-<product>.tar
    4. (Server and ArcIMS ArcMap Server Only) Stop your server.

        % arcgis/scripts/stopserver (Server)
        % $AIMSHOME/qs_scripts/stop_arcims (ArcIMS ArcMap Server)
    5. Start the installation by typing:

        % ./applypatch

      This will start the dialog for the menu-driven installation procedure. Default selections are noted in parentheses ( ). To quit the installation procedure, type 'q' at any time.

    6. (Server and ArcIMS ArcMap Server Only), type:

        Open a new terminal, type:

        % arcgis/scripts/startserver (in the new terminal) (Server)
        % $AIMSHOME/qs_scripts/start_arcims (in the new terminal) (ArcIMS ArcMap Server)

Patch Updates

Check Online Support Center periodically for the availability of additional patches. New information about this Patch will be posted here.

    UPDATE 1/04/2008 - The ArcInfo Workstation setup file is now available for download.

How to identify which Patch is installed


Solaris/Linux

To find out what ArcGIS products are currently installed on your machine, download and extract the PatchFinder.tar and run PatchFinder utility from your local machine. This utility provides a report detailing which ArcGIS products and which service packs have been installed. The PatchFinder utility searches for the following ArcGIS products.

    ArcGIS Engine Developer Kit for C++
    ArcGIS Engine Developer Kit for the Java Platform
    ArcGIS Engine Runtime
    ArcGIS Server for the Java Platform
    ArcIMS
    ArcIMS Web ADF for the Java Platform
    ArcInfo Workstation
    ArcReader
    ArcSDE

Extract the tar file by typing:

% tar -xvf PatchFinder.tar

Run the utility by typing:

% ./PatchFinder

Getting Help

Domestic sites, please contact ESRI Technical Support at 1-888-377-4575, if you have any difficulty installing this Patch. International sites, please contact your local ESRI software distributor.