English

ArcGIS Desktop 9.2 Synchronizing a Replica Errors Patch

Summary

This Patch is now obsolete. It has been superceded by the ArcGIS 9.2 Service Pack 3 and 4.

Description

IMPORTANT NOTE:

This Patch is now obsolete. It has been superceded by the ArcGIS 9.2 Service Pack 3.

Introduction

ESRI® announces the ArcGIS Desktop 9.2 Synchronizing a Replica Errors Patch. This Patch solves a case where after taking a replica out of conflict, the synchronization version is not removed and errors are returned when manually trying to delete it. We recommend that all who use geodatabase replication, download and install this Patch at their earliest convenience to ensure the highest quality experience when working with ArcGIS 9.2. It deals specifically with the issues listed below under Issues Addressed with this Patch.

Issues Addressed with this Patch


    NIM008366 - The synchronization version can’t be removed after reconciling and posting with the replica.

    Description

    During the synchronization process, changes are loaded into a temporary version on the target geodatabase and then reconciled and posted into the replica version. Reconcile and post may fail due to another user on the system who is also reconciling against the same version at the same time and has it locked. The synchronization process errors in this case and returns a message stating the replica version is locked. At this point the replica that was receiving changes (target) appears as if in conflict. If the synchronization version is still present after going through the steps for taking the replica out of conflict, you will have experienced the problem solved by this patch.

    At this point, if you try to manually delete the synchronization version, you will get an error stating that the replica_receive_rec version can’t be created. Since this version can’t be deleted, you will not be able to send changes from this replica. To remove the synchronization version, synchronize changes again from the source geodatabase to your target geodatabase. Once this successfully completes, you will no longer be in a state where the synchronization version can not be removed.

    After installing the patch and running into the same situation, the steps for taking the replica out of conflict will work properly and you will no longer experience the problem.

Files Installed in this Patch

  • Under the C:\Program Files\ArcGIS\Bin folder:

      GeoDBReplication.dll

Patch Updates

Check Online Support Center periodically for the availability of additional patches. New information about this Patch will be posted here.

This Patch is now obsolete. It has been superceded by the ArcGIS 9.2 Service Pack 3.

How to identify which Patch is installed

To check for the presence of a Patch, for each file examine the File version information (right click, properties, version tab). With only a few exceptions, all files modified as part of a Patch distribution can be uniquely identified in this manner. The File version for this Patch should read:

    9.2.2.1354

Getting Help

Domestic sites, please contact ESRI Technical Support at 1-888-377-4575, if you have any difficulty installing this Patch. International sites, please contact your local ESRI software distributor.