English

ArcIMS 9.1 Service Pack 2

Summary

ESRI announces ArcIMS 9.1 Service Pack 2. Please download and install this required Service Pack at your earliest convenience.

Description

ArcIMS 9.1 Service Pack 2

Important Note

A CD of this Service Pack is available for users who experience difficulties downloading the Service Pack from the web site. Simply fill out the Request a Service Pack CD order form.

ArcIMS 9.1 SP2 is currently not certified for use with Route Server 9.1. A new version of ArcIMS Route Server, that is compatible with ArcIMS Service Pack 2, will be released on 8/15/06.


Installing this Service Pack


Windows Installation Notes:

    It is important to keep the all versions of ArcGIS products installed on a machine in sync to avoid any software conflicts.

    To find out what products are currently installed on your machine, download the ServicePackFinder91.exe utility and run it from your local machine. This utility provides a report detailing which ArcGIS products are currently installed on your machine. This will help determine which product Service Packs you should install on your machine. The report also details which service packs have been installed. The report is displayed when the utility is run and a servicepack.txt log file is created in your temp folder. The Service Pack Finder utility searches for the following ArcGIS products.


      ArcGIS Desktop (ArcView, ArcEditor, ArcInfo) Includes the ArcReader fixes for the ArcReader FEATURE.
      ArcGIS Desktop Developer Kit
      ArcGIS Engine Runtime
      ArcGIS Engine Developer Kit
      ArcGIS Server
      ArcGIS Server .NET ADF
      ArcGIS Server Java ADF
      ArcGIS Tutorial Data
      ArcReader standalone
      ArcIMS
      ArcSDE


    NOTE (ArcSDE and ArcGIS Desktop users): If you use ArcSDE 9.1 or ArcGIS Desktop 9.1, you must also install ArcSDE 9.1 Service Pack 2 or ArcGIS 9.1 Service Pack 2. For example, if you use ArcIMS 9.1 and ArcSDE 9.1, install both ArcIMS 9.1 Service Pack 2 and ArcSDE 9.1 Service Pack 2. Since ArcIMS 9.1, ArcSDE 9.1 and the ArcGIS 9.1 products share common DLLs, it is important to keep the software release versions in sync to avoid any software conflicts.

    NOTE (ArcGIS Server users): If you have ArcGIS Server 9.1 and any other ArcGIS product installed on your machine, we recommend that you install the ArcGIS 9.1 Server Service Pack before installing the remaining Service Packs. Since ArcGIS Server and the ArcGIS 9.1 products share common DLLs, it is important to keep the software release versions in sync to avoid any software conflicts.

Installation Steps for Windows

ArcIMS 9.1 must be installed before you can install this Service Pack.

  1. Download ArcIMS91sp2.msp.   (71 MB).
  2. From your Services control panel, stop the ArcIMS Tasker, ArcIMS Monitor, and ArcIMS Application Server (in that order).
  3. Double-click the ArcIMS91sp2.msp to start the install process. This executable will take some time to examine your current ArcIMS install during the initializing stage. If double clicking the MSP file does not start the Service Pack installation, you can run the Service Pack manually by using the following command:

    msiexec.exe /p [location of service pack]\ArcIMS91sp2.msp REINSTALL=ALL REINSTALLMODE=omus

  4. When Setup starts, follow the instructions on your screen.
  5. After the Setup has finished, stop the Web Server and Servlet Engine and then run the ArcIMS Post Installation. The post installation setup can be run from Start > Programs > ArcGIS > ArcIMS > ArcIMS Post Installation.

    • If any of the following directories and files exists, please cut and paste them to a back-up location prior to running the Post Install. Remember to replace any customized files after running the post-install with the backed-up/original files. (e.g. the aimsmeta.properties, esriadmin.properties, Esrimap_prop files.)
      • \advancedmetadataexplorer
      • \cswconnector
      • \esriadmin
      • \jspsamples
      • \jspviewer
      • \metadataexplorer
      • \wfsconnector
      • \advancedmetadataexplorer.war
      • \cswconnector.war
      • \esriadmin.war
      • \jspsamples.war
      • \jspviewer.war
      • \metadataexplorer.war
      • \wfsconnector.war

  6. In the Post Install, choose the Custom Install option
  7. Check the box for ArcIMS Configuration
  8. Check the box for Web Server – Servlet Engine Configuration
  9. Check the box for ArcIMS JRE Configuration for Manager.

    In the ArcIMS JRE Configuration dialog no changes are necessary, simply keep the defaults and click Next.

  10. Uncheck all other options.
  11. Follow the prompts as explained in the ArcIMS Installation Guide and finish the Post Installation.

      Note: If your Web Server is not available as a selection in the Post Installation, please follow the manual instructions found in the ArcIMS Installation Guide to re-configure your web-server/servlet engine and to re-deploy ESRI war files. You will need to follow the uninstallation procedure found the in ArcIMS Install guide to remove deployed ESRI war files from your web-server/servlet engine before re-deployment. The war files that have been updated are:
      • advancedmetadataexplorer.war
      • cswconnector.war
      • esriadmin.war
      • jspsamples.war
      • jspviewer.war
      • metadataexplorer.war
      • wfsconnector.war
      • wmsfsconnector.war

  12. The post install will start the ArcIMS Application Server, ArcIMS Monitor and ArcIMS Tasker services. You may need to restart any additional ArcIMS services that may have been stopped for the install.

UNIX/Linux Installation Notes

It is important to keep the all versions of ArcGIS products installed on a machine in sync to avoid any software conflicts.

To find out what ArcGIS products are currently installed on your machine, download and extract the PatchFinder.tar and run PatchFinder utility from your local machine. This utility provides a report detailing which ArcGIS products and which service packs have been installed. The PatchFinder utility searches for the following ArcGIS products.

    ArcGIS Engine Runtime
    ArcGIS Reader
    ArcGIS Server
    ArcIMS
    ArcInfo Workstation
    ArcSDE

Extract the tar file by typing:

% tar xvf PatchFinder.tar

Run the utility by typing:

% ./PatchFinder

Installation Steps for UNIX/Linux

ArcIMS 9.1 must be installed before you can install this Service Pack.

  1. Stop the ArcIMS Tasker, ArcIMS Monitor, and ArcIMS Application Server (in that order) or use the script $AIMSHOME/qs_scripts/stop_arcims.


  2. Back up any customized files within your ArcIMS installation if they are listed in the Files Installed by this Service Pack page for UNIX/Linux. (e.g. the aimsmeta.properties, esriadmin.properties, Esrimap_prop files.)


  3. Extract the tar file ims91-sp2-<platform>.tar by typing:

    % tar -xvf ims91-sp2-<platform>.tar

  4. Start the installation by typing:

    % ./applypatch

  5. Follow the instructions in the install dialogue. It is recommended that you backup your original files when the dialogue asks.


  6. For Solaris and Linux ArcMap Server installations only:

    There are no ArcMap Server updates in Service Pack 2. However, as this service pack is cumulative, if you utilize ArcMap Server you should install the updates from Service Pack 1.

    • Download the appropriate ArcMap Server compressed tar file:
      Linux: ims91-sp1-gis-linux.tar.Z  (4 MB)
      Solaris: ims91-sp1-gis-sun.tar.Z  (7 MB)
    • %cp ims91-sp1-gis-<platform>.tar.Z <Path to ArcGIS ArcMap Server Installation>/arcgis/.
    • %uncompress ims91-sp1-gis-<platform>.tar.Z
    • If you want to back up your ArcMap Server files before applying the patched files:
    • Linux: %tar cf ims91-sp1-gis-linux_bak.tar -T ims91-sp1_filelist.linux
    • Solaris: %tar cf ims91-sp1-gis-sun_bak.tar -I ims91-sp1_filelist.sun
    • Check that the backup tar file was created properly:
      %tar tvf ims91-sp1-gis-<platform>_bak.tar
    • Extract the ims91-sp1-gis-<platform>_extract.tar:
      %tar xvf ims91-sp1-gis-<platform>_extract.tar

  7. To finish the ArcIMS service pack install run the <Path to ArcIMS Install>/tools/SetupArcIMS_PostInstall to propogate updated jar files to your JRE/JDK locations.


  8. The Post Installation should include running the <Path to ArcIMS Install>/tools/SetupArcIMS_WebConfig as the root user in order to redeploy the war files that have been updated.


    • TOMCAT USERS ONLY: Stop the Tomcat processes, then navigate to <Tomcat Installation Directory>\webapps. If any of the following directories and files exist, please move them to a backup location prior to running the Post Install and Web Configuration. These must be removed from the webapps directory. Remember to replace any customized files after running the post-install with the backed-up/original files. (e.g. the aimsmeta.properties, esriadmin.properties, Esrimap_prop files.)

      \advancedmetadataexplorer
      \cswconnector
      \esriadmin
      \jspsamples
      \jspviewer
      \metadataexplorer
      \wfsconnector
      \wmsconnector
      \advancedmetadataexplorer.war
      \cswconnector.war
      \esriadmin.war
      \jspsamples.war
      \jspviewer.war
      \metadataexplorer.war
      \wfsconnector.war
      \wmsconnector.war
  9. Start the ArcIMS Tasker, ArcIMS Monitor, and ArcIMS Application Server (in that order) or use the script $AIMSHOME/qs_scripts/start_arcims.


  10. If you installed ArcIMS 9.1 SP1, you may skip this step. If you did not install ArcIMS 9.1 SP1, there are several additional steps for UNIX/Linux users that make use of Java Custom or Java Standard websites. The Windows client JRE for the <Path to ArcIMS Website>/install directory will need to be updated to JRE 1.4.2_06. It is the same file for all UNIX/Linux platforms.

    Download ims91-sp1-viewer_jre_UNIX.tar

  11. Copy ims91-sp1-viewer_jre_UNIX.tar to <Path to ArcIMS Website>/install


  12. Delete or move the current JRE version that exists in the <Path to ArcIMS Website>/install directory.


  13. Extract the new j2re-1_4_2_06-windows-i586-p.exe from the tar file:

    % tar xvf ims91-sp1-viewer_jre_UNIX.tar

  14. No restart of the web server or ArcIMS is necessary for this update.


Configuring ArcIMS -- WFS Connector documentation (UNIX/Linux and Windows)


The Customizing ArcIMS - WFS Connector Guide was released with ArcIMS 9.1 SP1, you can access it from here or you can save it to your system:
Customizing ArcIMS - WFS Connector .


How to identify which Service Pack is installed


UNIX and Linux:

To find out what ArcGIS products are currently installed on your machine, download and extract the PatchFinder.tar and run PatchFinder utility from your local machine. This utility provides a report detailing which ArcGIS products and which service packs have been installed. The PatchFinder utility searches for the following ArcGIS products.

    ArcGIS Engine Runtime
    ArcGIS Reader
    ArcGIS Server
    ArcIMS
    ArcInfo Workstation
    ArcSDE

Extract the tar file by typing:

% tar xvf PatchFinder.tar

Run the utility by typing:

% ./PatchFinder

Windows:

To find out what products are currently installed on your machine, download the ServicePackFinder91.exe utility and run it from your local machine. This utility provides a report detailing which ArcGIS products are currently installed on your machine. The report also details which service packs have been installed. The report is displayed when the utility is run and a servicepack.txt log file is created in your temp folder. The Service Pack Finder utility searches for the following ArcGIS products.

ArcGIS Desktop (ArcView, ArcEditor, ArcInfo)
Includes the ArcReader fixes for the ArcReader FEATURE.
ArcGIS Desktop Developer Kit
ArcGIS Engine Runtime
ArcGIS Engine Developer Kit
ArcGIS Server
ArcGIS Server .NET ADF
ArcGIS Server Java ADF
ArcGIS Tutorial Data
ArcReader standalone
ArcIMS
ArcSDE

Service Pack Updates


Check the Online Support Center periodically for the availability of additional patches. New information about this patch will be posted here.

July 28, 2006: Added note regarding Route Server and ArcIMS 9.1 Service Pack 2 in Important Note section.
August 23, 2006: Added note regarding release of new version of ArcIMS Route Server.

June 29, 2007: Fixed typographical error.

Getting Help


Domestic sites, please contact ESRI Technical Support at 1-888-377-4575, if you have any difficulty installing this patch. International sites, please contact your local ESRI software distributor.